Seventh String Software

Linux Distro Information for Transcribe! 8.6 - 8.7

This page is for collecting info about running Transcribe! 8.6 - 8.7 on different Linux distros. I do not intend to test it myself on all of the dozens of distros available - life is too short. So instead, I am collecting feedback here from people who have tried it.

If you have useful information then do let me know - andy@seventhstring.com - and I will add it here. For example that some particular distro does work with Transcribe! 8.7, or that it doesn't and what the problem is, and how to solve that problem if you managed to.

Here is the list of required libraries (direct dependencies):
andy@ubuntu:~$ objdump -x transcribe | grep NEEDED
NEEDED libX11.so.6
NEEDED libSM.so.6
NEEDED libgtk-3.so.0
NEEDED libgdk-3.so.0
NEEDED libgdk_pixbuf-2.0.so.0
NEEDED libpangocairo-1.0.so.0
NEEDED libpango-1.0.so.0
NEEDED libcairo.so.2
NEEDED libgobject-2.0.so.0
NEEDED libglib-2.0.so.0
NEEDED libgstreamer-1.0.so.0
NEEDED libgstapp-1.0.so.0
NEEDED libgstvideo-1.0.so.0
NEEDED libdl.so.2
NEEDED libstdc++.so.6
NEEDED libm.so.6
NEEDED libgcc_s.so.1
NEEDED libpthread.so.0
NEEDED libc.so.6

Ubuntu

Transcribe! 8.7 was built on Xubuntu 14.04 and I also tested it (briefly) on 16.04. So it should be ok on current Ubuntu versions.

Fedora 25

Make sure you have Transcribe! 8.7 (not 8.6) and all should be well. See the note below about Wayland.

Gentoo

I have reports that it works fine, no known issues.

Open Suse 42.1

I have reports that it works fine, no known issues.

AV Linux 2016

I have reports that it works fine, no known issues.

Arch Linux

I have reports that it works fine.
You might need to select an appropriate output device for Transcribe! via the "Pulse Audio Volume Control" gui (under "playback").

Slackware 14.2

I have reports that it works fine, no known issues.

KxStudio

I have reports that KxStudio is still using the obsolete GStreamer version 0.1, therefore you may find that the older 8.4 version of Transcribe! will work better. See the FAQ here.

Problems outputting sound

On some distros, some people find that Transcribe! freezes when you try to play audio, or takes several seconds to start. It seems to be especially common on distros with low latency kernels and Jack audio (including Librazik and KxStudio). If this happens to you then please see the FAQ here.

About X11 and Wayland

Some distros are starting to use the Wayland compositor by default (e.g. Fedora 25). Transcribe! can only run on the X11 back end. However for compatibilty, distros using Wayland also include the X11 backend and Transcribe! will request this. If your distro defaults to Wayland then make sure you have Transcribe! 8.7 (not 8.6) and all should be well.